Архив рубрики ‘На заметку’

Ошибка доступа к файлу Excel в клиент серверной архитектуре из 1С 8.3

Ошибка доступа к файлу Excel  в клиент серверной архитектуре из 1С 8.3

Excel = Новый COMОбъект("Excel.Application");
Книга = Excel.WorkBooks.Open("D:\Dst\Order.xls");

Решение
на сервере убиваем excel (taskkill /im excel.exe /f)
открываем оснастку "Службы компонентов" (Пуск->Администрирование->Службы компонентов) или выполняем команду "mmc comexp.msc /32"
в ней раскрываем ветку Службы компонентов->Компьютеры->Мой компьютер->Настройка DCOM
справа в списке находим Microsoft Excel Application, открываем Свойства, вкладка Удостоверение, выбираем "Текущий пользователь", ОК.

Исправление не до контакта в плате управления колоннами в системе штрих-кодирования.

Стандартный штекер и разъем на плате, поставлены уже сотнями штук, выдал не до контакт внутри соединения.

Столкнулись с проблемой: плата управления не хотела связываться с программой на сервере. Пакет от колонн по 485 интерфейсу попадали на серверную плату, а в канал 232 уже не доходили. Кабель сразу проверили, проблема не в нем. Вот с помощью осцилографа нашли причину

влениеp1120720 p1120721 p1120722 p1120723 p1120724

Не запускается компьютер Windows 10 синий экран boot\bcd 0xc000014c

Не запускается компьютер Windows 10  синий экран boot\bcd 0xc000014c

p1120713

Лечиться путем загрузки с загрузочного диска Windows 10 или флешки и запуска командной строки в утилите восстановления. Там пересоздаются загрузочные записи.

Хороший видео пример:  https://www.youtube.com/watch?v=-Ne6C3i54rM

Результат ремонта

Установка модуля печати двухмерного штрих-кода PDF417 в 1С

pdf417

PDF417 — это двухмерный штрих-код, поддерживающий кодирование большого объема информации (до нескольких страниц текста). В настоящее время PDF417 широко применяется при сдаче отчетности в контролирующие органы.

Такой код считывается с помощью специального сканера и позволяет быстро и безошибочно считывать информацию с документов. Это сделано с целью повышения эффективности ввода данных с бумажных носителей, то есть для быстрого считывания бухгалтерской и налоговой отчетности, подготовленной на машиночитаемых бланках с нанесением двухмерного штрих-кода символикиPDF417.

Для печати машиночитаемых форм налоговых деклараций с двухмерным штрих-кодом PDF417 необходимо, чтобы на компьютере пользователя был установлен единый модуль печати машиночитаемых бланков и шаблоны машиночитаемых бланков.

Поддержка технологии формирования машиночитаемых бланков с двухмерным штрих-кодом включена в комплект форм регламентированной отчетности 1С.

Скачать последнюю версию модуля двухмерный штрих-код PDF417 можно на сайте ФГУП «ГНИВЦ ФНС России» по ссылке http://www.gnivc.ru/software/software_ul_fl/pdf417/

Видеонаблюдение Линия Devline Камеры Ubiquiti AirCam Ubnt

Настройка IP видеокамеры Ubiquiti AirCam Ubnt с программой видеонаблюдения Линия Devline

IP адрес камеры 192.168.2.104

Имя пользователя и пароль (по умолчанию) ubnt

Основной поток rtsp://ubnt:ubnt@192.168.2.104:554/live/ch00_0

Дополнительный поток rtsp://ubnt:ubnt@192.168.2.104:554/live/ch01_0

линия

 

 

Удаление всплывающих окон Opera

bannery_v_proshloe

Для удаления всплывающих окон нужно убедиться какое приложение их вывод.

Есть несколько вариантов:

  1. Всплывающие окно обведено и подписано названием программы запускающей неё.

Для удаления такого окна нужно проверить последние установленные в системе программы. Для этого нажимаем кнопку Пуск — Панель Управления.

пу1

В появившемся окне нужно убедиться, что в правом крайнем углу выбран режим отображения панели управления Категория. Далее нажимаем кнопку Удаление программы.

пу2

В появившемся окне Программы и компоненты отсортируем установленные программы по времени установки

пу3

Сделаем так, чтобы последние установленные программы были отсортированы вверх.

Теперь вверху списка ищем программы с названиями аналогичными появляющимся всплывающим окнам. Такие программы можно удалить.

пу4

2. Всплывающие окно появляется каждый раз при запуске браузера.

Скорее всего программа открывающая такие окна установлена в виде расширения браузера. Открываем Opera нажимаем кнопку Меню в левом верхнем углу и выбираем пункт Расширения — Менеджер расширений

опера1

В открывшемся окне нажимаем кнопку Включенные. Проверим, что список включенных расширений должен быть пуст. Если есть установленные расширения их можно тут же удалить.

опера2

 

1с 8 Конфигурация узла распределенной ИБ не соответствует ожидаемой

obmen1

1с 8 Бухгалтерия не проходит обмен между узлами РИБ (распределенной информационной базы)

При обмене выходит сообщение: Конфигурация узла распределенной ИБ не соответствует ожидаемой

Ошибка возникает при аварийном завершении работы программы. Для исправления нужно в ручном режиме перенести конфигурацию центральной базы на периферийную:

  1. Делаем резервные копии обоих баз
  2. Заходим в центральную базу в режиме Конфигуратор и жмем «Конфигурация — Сохранить конфигурацию в файл…»
  3. Полученный файл переносим в папку с периферийной базой 1с
  4. Отучиваем перефирийную базу от центральной: заходим в перефирийную базу в режиме Предприятия и запускаем обработку УстановкаОсновногоУзла, жмем кнопку Снять. После выполнения закрываем 1с.1с2
  5. Заходим в перефирийную базу в режиме Конфигуратор и временно снимаем её с поддержки: Включаем  возможность изменения и кнопку Снять с поддержки.1с
  6. Загрузим полученный файл конфигурации в п.2 из центральной базы Жмем «Конфигурация — Загрузить конфигурацию из файла…» Соглашаемся со всеми вопросами. После загрузки жмем клавишу F7 для применения новой конфигурации.
  7. Выходим из режима Конфигуратор перефирийной базы и заходим в неё в режиме Предприятие. Далее запускаем обработку УстановкаОсновногоУзла, выбираем в ней центральный узел (узел центральной базы 1с): нажимаем Т и выбираем Полный, далее из списка вашу центральную базу. Жмем Установить узел. Закрываем обработку. Перезапускаем 1с.

Проблема устранена и можно делать обмен в обычном режиме.

УстановкаОсновногоУзла

Windows 10 Не открываются фотографии. Невозможно открыть, используя встроенную учётную запись администратора

windows-10-uac-2

Windows 10 «Приложение» невозможно открыть, используя встроенную учётную запись администратора. Войдите с другой учётной записью и попробуйте ещё раз

Связано это с системой контроля учетных записей.

Нажмите кнопку пуск и наберите слово UAC и нажмите на появившуюся программу Изменение параметров контроля учетных записей

windows-10-uac

или зайдите в  Панель Управления->Учётные записи пользователей->Изменить параметры контроля учётных записей

windows-10-uac-2

Поставьте бегунок на второй пункт сверху  и нажмите кнопку ОК.

Затем перезагрузитесь и проверьте, что приложение запускается

 

Сравнение обычной аналоговой видеокамеры с HD камерами TVI и IP

hd-tvi

В ходе сравнения можно убедиться, что изображение с TVI камеры и IP в несколько раз лучше. В них уже можно разобрать номера машин и лица людей. По стоимости на март 2016 г. за уличную TVI камеру берут 4300 рублей,  за обычную аналоговую камеру 3500 рублей и за IP 5600 рублей.

При просмотре видео поставьте разрешение HD!

 

Трактир FrontOffice v3, v4: Отчет сверка итогов платежный терминал

Безымянный

Отчет сверка итогов: один платежный терминал для приема оплаты на 2-е организации

Столкнулся с проблемой, что снимая отчет платежной системы Сверка итогов чек выходит на одну организацию.
Это связано с тем, что в Front-Offcie 3 и 4 можно выбрать только один платежный терминал для одного рабочего места.
Проблему решил внеся изменения в конфигурацию.
Выкладываю свой код:
1. Добавим два поля в документ ТранзакцияПлатежнойСистемы : ИмяКомпьютера Строка 50, Выгружен Булево
2. Обработка Обслуживание_ПС_АТОЛ :
2.1. Заменить строку: «Если DRV.ResultCode = 0 ИЛИ ( DRV.ResultCode <= -10000 И DRV.ResultCode > -11000) тогда» на
»    Если DRV.ResultCode = 0 ИЛИ ( DRV.ResultCode <= -10000 И DRV.ResultCode > -11000) тогда

//ДВП 20012016
ИмяКомп=ИмяКомпьютера();
//ДВП
»
2.2. Заменить строку: «Док.ИДТерминала            = DRV.TerminalID;» на
«Док.ИДТерминала            = СокрЛП(CurrentDeviceNumber);//DRV.TerminalID;»
2.3. Заменить строку: «Док.Записать();»    на    »
//ДВП 20012016
Док.ИмяКомпьютера        = ИмяКомп;
Док.Выгружен            = ЛОЖЬ;
//ДВП;
Док.Записать();»
2.4. В процедуре СнятьОтчет добавить в запрос и параметры запроса поля Выгружен и ИмяКомпьютера
«//ДВП 23032016
Запрос = Новый Запрос(«ВЫБРАТЬ Ссылка,
|    ИДТерминала,
|    ДатаТранзакции,
|    ВремяТранзакции,
|    НомерКарты,
|    СрокДействияКарты,
|    ТипОперации,
|    КодАвторизации,
|    Сумма,
|    ТипТранзакции,
|    КодОтвета,
|    НомерСлипа,
|    НомерСообщения,
|    СсылочныйНомер,
|    Выгружен,
|    ИмяКомпьютера
|ИЗ
|    Документ.ТранзакцияПлатежнойСистемы
|ГДЕ
|    ИДТерминала = &ИДТерминала
//|   И ПлатежнаяCистема = &ПлатежнаяCистема
|    И ИмяКомпьютера = &ИмяКомпьютера
|   И Выгружен = &Выгружен
|ДЛЯ ИЗМЕНЕНИЯ
|»);

//Запрос.УстановитьПараметр(«ПлатежнаяCистема», ТО.Ссылка);
Запрос.УстановитьПараметр(«ИДТерминала», СокрЛП(CurrentDeviceNumber));//СокрЛП(ПараметрыДействия.НомерТерминала));
Запрос.УстановитьПараметр(«Выгружен», ЛОЖЬ);
Запрос.УстановитьПараметр(«ИмяКомпьютера», ИмяКомпьютера());
//ДВП;»
2.5. Заменить строку »    Пока Выборка.Следующий() Цикл
ДокОбъект = Выборка.Ссылка.ПолучитьОбъект();
ДокОбъект.Удалить();
ДокОбъект.Записать();
КонецЦикла;» на

»        Пока Выборка.Следующий() Цикл
ДокОбъект = Выборка.Ссылка.ПолучитьОбъект();
//ДВП 20012016
//ДокОбъект.Удалить();
ДокОбъект.Выгружен = ИСТИНА;
ДокОбъект.Записать();
//ДВП;
КонецЦикла;»
3. Обработка ОткрытиеЗакрытиеСмены
3.1. Заменить строки »        ИначеЕсли Лев(СтрокаДействий.Действие,8) = «ОтчетПС_» Тогда
Если НЕ Защита.ОтчетПлатежнойСистемы( Сред(СтрокаДействий.Действие,9) ) Тогда
Возврат Ложь;
КонецЕсли; » на
«ИначеЕсли Лев(СтрокаДействий.Действие,8) = «ОтчетПС_» Тогда
//Если НЕ Защита.ОтчетПлатежнойСистемы( Сред(СтрокаДействий.Действие,9) ) Тогда
//    Возврат Ложь;
//КонецЕсли;
НетОшибок=Истина;
Если НЕ Защита.ОтчетПлатежнойСистемы( Сред(СтрокаДействий.Действие,9) ) Тогда
//ДВП 20012016 Возврат Ложь;
НетОшибок=Ложь;
КонецЕсли;
//ДВП 20012016
ВрПлатежнаяСистема=глПараметрыРМ.ПлатежнаяСистема;
ВрПлатежнаяСистемаНомерТерминала=глПараметрыРМ.ПлатежнаяСистемаНомерТерминала;
ВрПлатежнаяСистемаПринтерСлипов=глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов;
глПараметрыРМ.ПлатежнаяСистема=Справочники.ТорговоеОборудование.НайтиПоКоду(«16»);
глПараметрыРМ.ПлатежнаяСистемаНомерТерминала=2;
глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов=Справочники.ТорговоеОборудование.НайтиПоКоду(«18″);
Если НЕ Защита.ОтчетПлатежнойСистемы( Сред(СтрокаДействий.Действие,9) ) Тогда
//глПараметрыРМ.ПлатежнаяСистема=ВрПлатежнаяСистема;
//глПараметрыРМ.ПлатежнаяСистемаНомерТерминала=ВрПлатежнаяСистемаНомерТерминала;
//глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов=ВрПлатежнаяСистемаПринтерСлипов;
//ДВП 20012016 Возврат Ложь;
НетОшибок=Ложь;
КонецЕсли;
глПараметрыРМ.ПлатежнаяСистема=ВрПлатежнаяСистема;
глПараметрыРМ.ПлатежнаяСистемаНомерТерминала=ВрПлатежнаяСистемаНомерТерминала;
глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов=ВрПлатежнаяСистемаПринтерСлипов;
Если НетОшибок=Ложь Тогда
Возврат Ложь;
КонецЕсли;
//ДВП;»
ВНИМАНИЕ!!! Далее нужно будет создать в оборудовании платежную систему №2 и Принтер слипов №2 к дополнение к первым. Их коды и используются при вызове.
4. Обработка РежимАдминистратора : Заменить строку
«Защита.ОтчетПлатежнойСистемы( ВыбМеню.Парам1);» на
«//ДВП 20012016
//Защита.ОтчетПлатежнойСистемы( ВыбМеню.Парам1);
//ЗапуститьПриложение(«c:\sverka.cmd»,,Истина);
Защита.ОтчетПлатежнойСистемы( ВыбМеню.Парам1 );
ВрПлатежнаяСистема=глПараметрыРМ.ПлатежнаяСистема;
ВрПлатежнаяСистемаНомерТерминала=глПараметрыРМ.ПлатежнаяСистемаНомерТерминала;
ВрПлатежнаяСистемаПринтерСлипов=глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов;
глПараметрыРМ.ПлатежнаяСистема=Справочники.ТорговоеОборудование.НайтиПоКоду(«16»);
глПараметрыРМ.ПлатежнаяСистемаНомерТерминала=2;
глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов=Справочники.ТорговоеОборудование.НайтиПоКоду(«18″);
Защита.ОтчетПлатежнойСистемы( ВыбМеню.Парам1 );
глПараметрыРМ.ПлатежнаяСистема=ВрПлатежнаяСистема;
глПараметрыРМ.ПлатежнаяСистемаНомерТерминала=ВрПлатежнаяСистемаНомерТерминала;
глПараметрыРМ.ПлатежнаяСистемаПринтерСлипов=ВрПлатежнаяСистемаПринтерСлипов;
//ДВП;
»

5. Алгоритм работы системы. В настройках рабочей станции указывается платежная система №1 и принтер слипов №1.
В справочники торговое оборудование создается Платежная система №2 (в примере код 16) и принтер слипов №2 (в примере код 18).
В Вашем случае коды оборудования будут свои, замените их в п. 3.1. и 4.
При продаже по карте фиксируется продажа документом ТранзакцияПлатежнойСистемы в котором заносится наименование компьютера, и ИД терминала,
устанавливается флаг Выгружен в ЛОЖЬ.
При сверки итогов флаг Выгруден становится в ИСТИНА.
Таким образом можно всегда свериться, что было пробито по карте в 1с. Если Вас будут стеснять накопленные данные продаж по карте,
можете в ручную почистить документы ТранзакцияПлатежнойСистемы с признаком Выгружен ИСТИНА.

Информацию даю как справочную. Вносимые изменения делаете, на Ваш страх и риск.